반응형
Notice
Recent Posts
Recent Comments
«   2024/05   »
1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31
Archives
관리 메뉴

Easy-So-Easy

Flutter 초반 세팅 및 오류 본문

Flutter

Flutter 초반 세팅 및 오류

섭_민 2023. 8. 28. 17:39
반응형

리눅스 환경을 기반으로 세팅하였음.

 

기본 세팅

 

1. Flutter 설치

sudo snap install flutter --classic

2. Flutter 설치 마무리( 버전 확인 커멘드 설치 마무리 진행 )

flutter --version

3. Flutter SDK 경로 확인 방법

flutter sdk-path

4. Flutter 종속성 확인

flutter sdk-path

 

 

 

 

에러 사항들

 

Android SDK에서 따로 설치해야할 경우

  • setting → Languages & Frameworks → Android SDK → (아래와 같이 설정)

Android SDK에서 따로 설치해야할 경우

** 가장 최신버전을 설치할 경우 flutter에서 지원을 하지 않을 수 있음

     → 오른쪽 하단 Show Package Details 체크

28.0.3으로 맞춰주자

이후 CLI 창으로 돌아와 아래 명령어를 다시 실행

flutter doctor --android-licenses

 

 

VsCode 에서 android emulator가 실행되지 않는 경우

1. AVD가 permission denined이 되어있을 경우

 

  • qemu-kvm 설치
sudo apt install qemu-kvm

 

  • adduser to kvm group
sudo adduser <username> kvm

 

  • own the file /dev/kvm using chown.
sudo chown <username> /dev/kvm

 

모두 마쳤으면 재부팅 후 다시 실행해보자.

 

2. emulator가 없을 경우 → emulator 생성

반응형

'Flutter' 카테고리의 다른 글

C.1  (0) 2023.08.29